現在地: セキュリティセンター > Mozilla Foundation セキュリティアドバイザリ > MFSA 2014-15

Mozilla Foundation セキュリティアドバイザリ 2014-15

タイトル: 様々なメモリ安全性の問題 (rv:28.0 / rv:24.4)
重要度: 最高
公開日: 2014/03/18
報告者: Mozilla 開発者
影響を受ける製品: Firefox、Thunderbird、SeaMonkey

修正済みのバージョン: Firefox 28
  Firefox ESR 24.4
  Thunderbird 24.4
  SeaMonkey 2.25

概要

Firefox やその他の Mozilla ベースの製品に搭載されているブラウザエンジンに含まれていたメモリ安全性に関するいくつかのバグを、Mozilla の開発者が特定、修正しました。これらの問題の一部は、特定状況下でメモリ破壊の形跡が見られ、条件が整えば任意のコード実行に悪用可能と思われるものでした。

Thunderbird と SeaMonkey では JavaScript が初期設定で無効になっているため、一般的にこれらの脆弱性はメールを通じた悪用が不可能です。ただしこれらの製品でも、ブラウザもしくはブラウザに類似した機能を利用した場合、潜在的なリスクが生じます。

参考資料

Firefox ESR 24.3 と Firefox 27 に影響するメモリ安全性の問題とクラッシュが、Benoit Jacob、Olli Pettay、Jan Varga、Jan de Mooij、Jesse Ruderman、Dan Gohman、Christoph Diehl によって報告されました。

Firefox 27 に影響するメモリ安全性の問題とクラッシュが、Gregor Wagner、Olli Pettay、Gary Kwong、Jesse Ruderman、Luke Wagner、Rob Fletcher、Makoto Kato によって報告されました。