現在地: セキュリティセンター > Mozilla Foundation セキュリティアドバイザリ > MFSA 2010-74

Mozilla Foundation セキュリティアドバイザリ 2010-74

タイトル: 様々なメモリ安全性の問題 (rv:1.9.2.13/1.9.1.16)
重要度: 最高
公開日: 2010/12/09
報告者: Mozilla の開発者とコミュニティ
影響を受ける製品: Firefox、Thunderbird、SeaMonkey

修正済みのバージョン: Firefox 3.6.13
  Firefox 3.5.16、Firefox 3.5.17
  Thunderbird 3.1.7
  Thunderbird 3.0.11
  SeaMonkey 2.0.11

概要

Firefox やその他の Mozilla ベースの製品に搭載されているブラウザエンジンに含まれていたメモリ安全性に関するいくつかのバグを、Mozilla の開発者が特定、修正しました。これらの問題の一部は、特定状況下でメモリ破壊の形跡が見られ、条件が整えば任意のコード実行に悪用可能と思われるものでした。

2011/03/01 更新: CVE-2010-3777 は Firefox 3.5.17 で修正されました。

参考資料

Firefox 3.6 と Firefox 3.5 に影響するメモリ安全性の問題が、Jesee Ruderman、Andreas Gal、Nils、Brian Hackett によって報告されました。

Firefox 3.6 のみで修正されたメモリ安全性の問題が、Igor Bukanov によって報告されました。

Firefox 3.5 のみに影響するクラッシュが、Jesse Ruderman によって報告されました。