現在地: セキュリティセンター > Mozilla Foundation セキュリティアドバイザリ > MFSA 2011-01

Mozilla Foundation セキュリティアドバイザリ 2011-01

タイトル: 様々なメモリ安全性の問題 (rv:1.9.2.14/1.9.1.17)
重要度: 最高
公開日: 2011/03/01
報告者: Mozilla の開発者とコミュニティ
影響を受ける製品: Firefox、Thunderbird、SeaMonkey

修正済みのバージョン: Firefox 3.6.14
  Firefox 3.5.17
  Thunderbird 3.1.8
  SeaMonkey 2.0.12

概要

Firefox やその他の Mozilla ベースの製品に搭載されているブラウザエンジンに含まれていたメモリ安全性に関するいくつかのバグを、Mozilla の開発者が特定、修正しました。これらの問題の一部は、特定状況下でメモリ破壊の形跡が見られ、条件が整えば任意のコード実行に悪用可能と思われるものでした。

参考資料

Firefox 3.6 と Firefox 3.5 に影響するメモリ安全性の問題が、Jesse Ruderman、Igor Bukanov、Olli Pettay、Gary Kwong、Jeff Walden、Henry Sivonen、Martijn Wargers、David Baron、Marcia Knous によって報告されました。

Firefox 3.5 のみに影響するメモリ安全性の問題が、Igor Bukanov によって報告されました。